7T Philips Data

Hi There!

I’m trying to process some 7T Philips data in Osprey and I’m running into snags.

It seems to be processing

strangely to my novice eye.

I think it isn’t recognizing the basis set (and also I think I’m getting the control file part wrong) because it’s having trouble quantifying in LCModel. I can only make it to the process step.

I’m pointing it to a basis set that was provided to go along with the data. LCModel control parameters were also provided but I seem to be not understanding how to load a proper control file into the job file for those parameters load.

Hi @Busler12,

Thanks for reaching out.

Could you post your job file? From what I can tell, you have to turn off the eddy current correction (ECC.metab = 0) in the job file.

This will hopefully solve the downstream problems. Let me know how the results look, and maybe you can also post your control file and model results.


Hi Helge!

Thanks for responding and so quickly!!

I’m attaching the job file (minus having the control file linked). Also attaching the control file. We got the control file parameters in an rtf file and I copied and pasted into WordPad to be able to make it a control file.

I reran the same two people with ECC = 0 for raw and mm and am also attaching that output.

When I do the modeling part I get the attached error.

Thanks for your help!

jobSDAT_LCModel_OS_JHU_Hub.m (13.2 KB)

7T_LCModel_Control_Params_3.txt (267 Bytes)
Screenshot 2024-07-03 115257
Screenshot 2024-07-03 115332

I’m assuming you see this error because LCModel didn’t run.
Likely because the LCModel control files need every single line to lead with a single space character (copying and pasting from an RTF file is likely to destroy that).

From the LCModel manual (section 5.2.1):

Namelists are used throughout LCModel. See your Fortran Manual for their many convenient features, or use the Namelists in your LCModel package as guides; Namelists are very easy to use. The one critical pitfall: the first column of Namelist input is always ignored; so each line must start with one space. The start of the Namelist is specified by a $ (which must be in column 2) followed by the Namelist name (e.g., $SEQPAR above). The end is specified by $END.

PS: I think switching ECC off did the trick for the data.
PS2: I would certainly toss out that second dataset for failed shim.

1 Like

ah yes… I did not put a space in front of each line. Thank you for passing along that detail!!!

When I reran the two sample subjects with ECC off and got the output you referenced below I didn’t not link to a control file at all because I knew mine wasn’t working. I thought Osprey generated it’s own in that case. Maybe I also have something else wrong too?

Hmm - can you try putting the path to the basis set file in curly brackets?
opts.fit.basisSetFile = {'S:\Basis Sets\Philips_7T_JHU\7T_STEAM_TE14TM33.basis'};
instead of
opts.fit.basisSetFile = "S:\Basis Sets\Philips_7T_JHU\7T_STEAM_TE14TM33.basis";

OK, this is a useful txt file, thanks. I’m not sure why the water data is not recognized. Can you post the .print file from the output folder for diagnosis? I’m slightly suspecting that the HWDWAT parameter might be the culprit but that’s just a guess (try removing it).

Another thing: I think Osprey doesn’t recognize some of the metabolite names in the basis set properly and therefore throws them out of the basis set. I will need to dig a little into that.

Note that Osprey, by default, always overwrites the relaxation-correction-related fields in the control file template (atth2o, attmet, wconc etc.) with values that make LCModel return pure, uncorrected water-scaled amplitudes. That is because Osprey performs its own relaxation correction in the subsequent steps (Coreg, Seg, Quantify). Any input that you give in your control file for these fields will not be used.

1 Like

Ah okay! Thanks. Good to know :slight_smile:

Also, I just found out I was given the wrong basis file for the data lol so… maybe that’s about to fix it self. :slight_smile:

Careful - I think that Osprey has removed some of the metabolites whose names it didn’t recognize (like m-Ins, s-Ins). I need to check that. Finally, I’m confused - does the basis set contain basis functions for MM? The control file Osprey generated seems to suggest that, but I don’t think MMs should be in the basis set itself.

Where did you get the basis set from? Can you upload it somewhere and post a link to it?

Thanks both of you for your help!! I now have the correct basis set and no longer needed to input specific control parameters and everything seems to run smoothly now!! I don’t get the h2oarea error anymore either.