Error when trying Osprey tutorial

Hi Georg and Helge. I am trying to go through the Osprey tutorial (documentation section 4) and run into the error below. I first tried on Mac OS Monterey 12.2.1 with Matlab 2022a. I saw on another thread that there was possibly an issue with newer Mac OS and/or Matlab versions, so I tried on another Mac with Catalina 10.15.7 with Matlab 2020a. I have the Optimization Toolbox, Statistics and Machine Learning Toolbox, GUI Layout Toolbox, Widgets Toolbox (compatibility support), and Xcode 12.4. Osprey and SPM12 are in the Matlab path. Any ideas what I’m doing wrong? Thanks! --Meredith

Reference to non-existent field ‘nExperiments’.

Error in OspreyGUI (line 202)
if gui.controls.nExperiments > 1

Error in Osprey/loadJob (line 123)

Error in Osprey/onLoadJob (line 166)

Error while evaluating UIControl Callback.

Hi @Meredith,

thank you for reaching out and for the detailed description of the problem.

Actually, this was a bug that we just became aware of today with multiple bug reports. I have just pushed a new version onto the develop branch (GitHub - schorschinho/osprey: All-in-one toolbox for processing of magnetic resonance spectroscopy data.) which should solve the issues.

Please let me know if this works for you!.


1 Like

Hi Helge,
Looks like it’s up and running. Thanks for the update!