Errors when processing NIfTI-MRS files in Osprey

Hi all,

I was trying to run two participants whose MRS data was in NIfTI-MRS format (converted using spec2nii via BIDScoin) through Osprey, and I encountered this error on the process function:

Timestamp May 17, 2023 10:03:58 Osprey 2.5.0  OspreyProcess
Processing data from dataset   1 out of   4 total datasets...
Matrix dimensions must agree.

Error in op_eccKlose (line 47)

Error in OspreyProcess (line 376)
                    [raw,raw_ref]                   = op_eccKlose(raw, raw_ref);        % Klose eddy current correction

Error in osp_onProc (line 37)
    MRSCont = OspreyProcess(MRSCont);
Error while evaluating UIControl Callback.

I got the same error when I selected a single roi instead of 2; when I selected a single participant (either participant); both a single roi and participant; and when I ran the analysis using the command line instead of the GUI.

I tried running the same data in Twix format and got the same error. Running the same data but in DICOM format works fine. The NIfTI-MRS files were generated from the individuals’ Twix files so this may indicate the source of the problem?

I was able to run the example Twix data provided with Osprey with no errors. When running the example NIfTI-MRS data I run into issues around the basis sets in the model stage (which I can share if that’d be helpful).

Do you know what the problem might be?


Hi @gmackie,

i guess if the error is occurring in both the Twix and the NIfTI, it suggests the issue is in the raw data, not necessarily the NIfTI routines or conversion. Was this sequence stopped before finishing, by any chance? Would you be able to share the data with me, so I can take a look?


Sent you an email, thanks!

I don’t believe the scan was stopped before finishing no. If the issue was with the raw data wouldn’t the DICOMs also not work? They seem to run fine.

1 Like