Flipped spectra in LCModel

Hi everyone,

Does anyone know why the spectra flipped upside down? Have tried to turn on and off for the eddy current correction but results look the same.

Any idea with these sets of data? Severe motion?

The first one should be salvagable, the other two are just total failure of shim or really anything, but hard to tell without seeing the whole spectrum.

What do these look like before you put them into LCModel? Have you pre-processed them in any way?

Hi Steve,
I know this problem especially when the data shift is too high. But that shouldn’t be the problem here.
Maybe the NAA signal is too low for referencing. You can try SPTYPE=’tumor’. Or alternatively you can test something like DEGZER = 180 to start with the right expected zero-order phase.
On the other two, I agree with @admin. Does the water suppression work?


I agree that the first spectrum seems to have a -0.1 ppm frequency offset - shifting it in the right direction might help already with the initial fit, DEGZER should be the next option indeed as @hraum says.

How can I shift the spectra manually by 0.1 ppm?
By the way, DEGZER = 180 works!

Thanks both.

Hi @stevehui ,

Maybe very strong water suppression? In certain cases some preprocessing can get confused if the residual water is inverted.

You can use PPMSHF=0.1 to set a starting shift, and optionally FIXSHF=T to force it to use your starting estimate even if it the model suggests otherwise. I don’t think it’ll help in this instance: in your first spectrum, it looks like the initial referencing has made a reasonable effort to align the inverted troughs to 3.0 and 3.2 ppm, which is where most of your shift (-.063ppm reported) is probably coming from.

So, DEGZER is the best option here, but I agree with @hraum that you probably also want to be using SPTYPE='tumor' for this dataset.

Section 11.3 of the LCModel manual has several pointers for other variables you can look at to control the referencing.