Help Needed with LCModel Fitting Gap for sLASER Data in Osprey


I’m working on sLASER data analysis and ran into an issue with applying a ppmgap in control file within the Osprey/Model data section.

Initially, I added the following lines in the control file:

ppmgap(1,1) = 1.85
ppmgap(2,1) = 1.1

But when I tried to fit the data, I got an error message:

FATAL ERROR MYCONT 2. (Check LCModel Manual).
This error occurred before the plot could be produced.
See the Diagnostics list in the LCModel Manual.

I also made changes to the job file by adding these commands and removing the control file entry: = [1.1 1.85]; = [1.1 1.85];

Unfortunately, this didn’t resolve the issue.

I’d really appreciate your help in figuring out how to properly set the ppmgap for LCModel fitting in Osprey.

Thanks for your assistance.

Best regards,

Hi Zeinab,

Sorry for the delay in responding to your requests. We’ve all been out of town for a while.

The gap parameter in the Osprey job file is currently only relevant if you use the Osprey fitting model. For use with LCModel, you will need to specify it in the template LCModel control file.


Hi Georg,

Hope you are well.
Thanks for your response and help.
I’ve made some modifications to the osp_realcm_control function to enable it to correctly read the following two commands from the control file: ```
ppmgap(1,1) = 1.85
ppmgap(2,1) = 1.1

As you can see from the screenshot I’ve attached, it appears to read these commands correctly:However, I’ve been encountering an issue in a later stage of the process where the following error message pops up, and the ppmgap commands in the control file generated by Osprey appear to be incorrect:

I’m finding it challenging to pinpoint the exact location where I should make modifications to address this issue. I was wondering if you could provide some guidance or assistance in resolving this.

By the way, I’m also unsure whether it is appropriate to use ppmgap in data with lipid contamination. Would you be able to review Helge’s response to my previous question and my follow-up for insights on this matter?

I appreciate your expertise and assistance with these matters.

Kind regards,

Hi @ZeinabEftekhari and all,

Are we sure this is an issue with ppmgap, and not something more generic with the control file? Do you get the same error if you just take away these lines, and keep everything else identical? Could you please forward a copy of your complete control file so we can see the issue in context?

LCModel manual (section 12.1.1) suggests that either quotes, invalid characters (incl leading space etc), or invalid variable names are the most likely cause of this error. It looks like you’re trying to run LCModel on a Windows system, which I don’t have any experience with – but I notice that the slashes in your file names are pointing in different directions for the filbas and filraw parts. I’m not certain that both are acceptable…

Hi @ZeinabEftekhari,

The Osprey LCModel wrapper wasn’t supporting the GAP parameter yet.

I have just pushed a new version to the develop branch that supports it. You can add the following line to the jobfile to include the GAP parameter: = [1.1 1.85]; % optional GAP parameter

And about the gap parameter in general. I’m not aware of any study that has systematically investigated the impact of excluding the lipid artifact this way. It is based on the recommendation in the LCModel manual to exclude the region during the modeling of MEGA-PRESS difference spectra.


Hi Helge,

Thanks a lot for solving my problem. The gap is now working nicely.
I will calculate the CV% and do some analysis with and without the gap to see the effect of lipid contamination on my data. Will let you know if it was significant.

Kind regards,

Hi Alex,

Thanks for your response.The issue was related to Osprey that could not support ppmgap in my control file for LCModel. When I deleted the command from the file, it worked with no issue. However, Helge could fix the code for suppring gap command and now works nicely.


1 Like