Install LCModel to a folder other than $HOME

Hello lovely MRS community!

I’m new to LCModel and I’m having some issues installing LCModel.

I’m working with a Linux workstation and don’t have root privileges. In addition, my $HOME folder has limtied memory and I don’t install anything to $HOME. For this reason, I’m trying to install LCModel to a different folder ($WD=‘export01/data’) where I have write privileges. I downloaded the LCModel tar file from Dr.Provencher’s website to $WD. Then I modified the install-lcmodel bash file so LCModel would be installed to $WD. The installation works without a glitch but I test run fails . It seems when LCModel runs the test run, it looks for some RAW files in my $HOME folder. I checked the $HOME folder for some LCModel files and found the following 4 folders:

This may be a cause for the errors.

TLDR, dooes anyone know how I can download LCModel fully to my $WD? Thank you so much for your help!

All the best,

The main lcmodel binary is basically agnostic to its location, provided you have all the paths correct in your input .control file – but I expect you’ll run into trouble with some of the ancillary commands (eg, the GUI, and some of the file conversion plugins which the GUI calls by default).

There may be cleaner solutions, but the way that I handle this scenario is with symbolic links. First thing to try would by a symbolic link from your home directory to $WD. You should first make sure you don’t have a .lcmodel folder there already…

[ -d ~/.lcmodel ] && mv -v ~/.lcmodel ~/.lcmodel.old   # move any pre-existing folder

ln -s ${WD}/your_lcmodel_folder ~/.lcmodel   # create symbolic link to preferred location

See if that works; if for some reason it does not, you might instead need to set up individual symlinks for all the separate subfolders under .lcmodel (this is the configuration I use, to achieve a combination of shared and user-specific data; it’s a bit more work setting up at first, but somewhat convenient when upgrading)

All that aside, LCModel itself is pretty small, so I’d be amazed if it didn’t fit into your home folder. Maybe you just need to be selective about where you have it write its temporary (and output) data, and perhaps (if space is really limited) where the basis sets are stored?

By the way: I assume there was a typo in your original message and that you have a leading slash in your $WD (should probably be $WD='/export01/data')… judging by the name, I guess this might be an NFS share, which might possibly introduce complications relating to permissions or timestamps – another avenue to investigate if it doesn’t work as described, but it sounds like that side of things is probably okay.