Multi voxel CSI - error in load MRSCont file with Osprey


I’m trying to use your tool with a multivoxel spectroscopy file (16x16 voxels) acquired with semiLASER sequence (on a Skyra Simens 3T).
I understand that when I create the job file I have to select either PRIAM or CSI. However, if I run from the GUI in the “data scenario” drop-down menu I don’t have the possibility to select CSI.
I tried to select then PRIAM but get the following error: “Unable to perform assignment because the size of the left side is 1-by-1024 and the size of the right side is 1-by-1024-by-16-by-16.”
I also tried to manually change the field data scenario in the .json file by putting CSI (“dataScenario”: “CSI”) and I get the same error.

How can I do to solve this issue?

Thank you!

Hi Marta,

Osprey is decidedly optimized to analyze single-voxel data at this point. We have a branch in the Osprey repository (‘MRSI’) that has some support for MRSI analysis, but I don’t think it would work out of the box for Siemens data (we are a Philips site locally).

You can try FSL-MRS or spant - I believe both of them are a little further along at this point in their support for MRSI.


1 Like