No appropriate basis set to model your data

Hello, wondering if anyone could help with this. I have a raw megapress data set in .SDAT format. When loading and processing everything is well but when fitting i get the following error:
“Error using osp_fitInitialise
There is no appropriate basis set to model your data. Please supply a sufficient basis set in Osprey .mat format in the
fit/basissets/user/BASIS_MM.mat file! Or supply a .BASIS file for LCModel”
It should work with the basis set already in Osprey but just in case I also tried one of mine that happens to work good in other packages and I still get the same error. I’m feeding it to the program by writing the path in
Thanks in advance

Dear Chavier,

thanks for reaching out!

Osprey is usually using an automated routine to identify the right basis set based on the supplied sequence parameters (TE, localization, etc.). In some cases it may fail, i.e. if TE is 69 ms instead of 68 ms which is what we would assume for GABA-edited data.

You can simply overwrite the basis set path and force Opsrey to use a certain basis set by adding the following line into your jobFile. You have to update the path according to your Osprey location and vendor. = '~/osprey/fit/basissets/3T/philips/mega/press/gaba68/basis_philips_megapress_gaba68.mat';

About using external basis sets:
It is possible to import .BASIS into Osprey using the io_LCMBasis function but this can be tricky sometimes.

Let me know if this works for you.