Questions about LC model installation

Dear MRSHub members,

Hi, I’m new to MRS analysis.

I’ve been recently trying to do MR Spectral quantitation using MR Spa and LC model.

The laboratory I’m working at has purchased LC model license, and my predecessors used it successfully.

I have successfully use MRspa to run ECC correction-Frequency correction-Phase correction and saved the result as .SPA file.

After that I tried running LCModel on that .SPA file as input and previously made basis file and the following error message pops up.

I found out that last year LC model became a free SW, and the error message is related to program license. I’m curious if the error has some thing to do with LC model being free SW?

And also as I’m trying to install LC model on my local PC, I downloaded lcm-64.tar from LC model homepage and tried installing it with command ./install-lcmodel, and the following message pops up.

couldn’t connect to display “”
while executing
“load /home/naarkeem/.lcmodel/lcmgui/lib/ Tk”
(“package ifneeded Tk 8.5.18” script)
invoked from within
“package require Tk 8.4”
(“package ifneeded Tix 8.4.3” script)
invoked from within
“package require Tix”
(file “/home/naarkeem/.lcmodel/lcmgui/lib/application/home/sp/main/projects/lcm/gui/universal/src/64-bit/t-to-wrap.tcl” line 1)
invoked from within
“source $startup”
(file “/home/naarkeem/.lcmodel/lcmgui/main.tcl” line 38)

Can anybody help me? I’m really lost here.



Hi NarlKim,

Looks like two separate problems. I don’t have an answer, but a couple of questions and pointers…

First, the output from MRSpa suggests to me that the basic lcmodel binary (command-line tool) is running, but without a license. Nowadays the license is a bit redundant (as you note), so you could either make sure your existing valid license file is in the right place, or just enable operation without the license, following the instructions under “News” here: LCModel's home page

As to the other problem: are both LCModel and MRSpa running directly on your local machine, or are they in some sort of container (docker?) or virtual machine? The first line (“couldn’t connect to display”) rather suggests an incorrectly-configured remote setup, but might be specific to the way tcl is trying to get permission to use your display. What platform are you using?

First thing to check is whether the DISPLAY variable is sensible; the IP address in the first line of your output is surprising; do you recognise that address ( From the command line where you’re running ./install-lcmodel, what do you see when you type “env | grep DISPLAY” ? The solution may involve the “xauth” command, but that depends on your setup.

In any case this issue only impacts GUI operation, so you should be able to use the command-line tool perfectly well; this may be enough for MRSpa…

Hope this helps a bit.