Siemens DICOM data not loading into Osprey

Dear MRSHub experts,

I’m very new to Osprey and MRS so please forgive any silly mistakes.

I have been trying to upload some DICOM files from a (Siemens) MEGA-PRESS acquisition into the Osprey GUI (have also tried using the command line - [MRSCont] = OspreyLoad(MRSCont) after creating an MRSCont file in the GUI).

I was wondering how long this process would normally take (I started with 240 DICOMs in one subject folder but reduced this to 10 DICOMs to see if it was taking ages because there were so many). Even after reducing the folder to 10 DICOM files, the process ran for 2 hours without opening the spectra in the GUI. There are no example DICOM data in the Github download so I’m unable to compare my jobfile or folder structure with the gold standard.

Importantly, there are no error messages printed in Matlab, so I’m a little lost as to what the issue might be

Would it be possible to please gain access to an example jobfile and dicom data to establish whether this is an error with my data/Matlab setup?

Thanks in advance!
Carolyn

P.S. I am able to open the DICOM files in JMRUI within a few seconds, so I don’t think it is the files per se.

Hi @CarolynMcNabb,

Thanks for getting in touch. Can you share the part of your job file where you set up the files, files_ref and files_w cells?

With DICOM files, it is important that you point to the folder that contains all DICOM files for a particular MRS sequence (and only those - don’t mix with other sequences or imaging files).

I’m surprised you’re not even getting an error message. Does MATLAB just stay in the ‘busy’ state forever?

Thanks,
Georg

Hi Georg,

Thanks so much for your reply. I’ve separated the DICOM images into separate folders so that the megapress data are in one folder and water reference data in another folder. I wasn’t able to determine from the manual whether ON and OFF spectra need to go into separate folders (they are in the same folder for now but I also tried them in separate folders and this did not help with the loading issue).

Please see below for job file details

files       = {'/Volumes/GoogleDrive/.shortcut-targets-by-id/1cY8uowl6lCM5Vb1IZUCwF8pFAqRh8X6C/MRS_data /s001/mrs/sub-01_megapress_onoff_striatum/',...
        '/Volumes/GoogleDrive/.shortcut-targets-by-id/1cY8uowl6lCM5Vb1IZUCwF8pFAqRh8X6C/MRS_data /s002/mrs/sub-02_megapress_onoff_striatum/'};


files_ref   = {'/Volumes/GoogleDrive/.shortcut-targets-by-id/1cY8uowl6lCM5Vb1IZUCwF8pFAqRh8X6C/MRS_data /s001/mrs/sub-01_press-ref_striatum/',...
    '/Volumes/GoogleDrive/.shortcut-targets-by-id/1cY8uowl6lCM5Vb1IZUCwF8pFAqRh8X6C/MRS_data /s002/mrs/sub-02_press-ref_striatum/'};


files_w     = {};

Yes, MATLAB just stays in the ‘busy’ state - also, the loading bar that usually comes up when I press load data using in the .SDAT example data doesn’t appear.

I was playing around with some of the functions today, trying to load the DICOMs using io_loadspec_dicom() and I am getting an error "Unable to perform assignment because the size of the left side is 1024-by-1 and the size of the right side is 0-by-1. " Not sure if this is related to the issue or not (I did just try this with one or two dicoms in the folder so it may be a completely different error).

I hope this is helpful.

Thanks so much,
Carolyn

Hi Carolyn,

The error message from io_loadspec_dicom is likely at the heart of it. Can you de-identify and share an example DICOM dataset, either via upload or e-mail (goel-removethisbitforspamprotection-tzs1(a)jhmi(dot)edu)

Thanks,
Georg

1 Like

Thank you, Georg.
I have shared some example data and the job script with you in OneDrive. Please let me know if you need anything else or have trouble accessing the folder.

Best wishes,
Carolyn