Vespa Shortcuts under MacOS installations

Dear community,
Thank you for the room here provided to questions and tips.
Back to my issue: I had installed Vespa on my MacOS (Catalina 10.15.7) following the online step by step procedure (New Vespa Installation · Vespa Documentation). Vespa-suite has been installed successfully. All of Vespa’s dependencies look fine and the Vespa shortcuts have been created too. However, there is no response when I double clicked any of the shortcuts, nothing showed up.

Then I tried the command below:
‘python /…/python3.7/site-packages/vespa/simulation/’
and it showed :
‘This program needs access to the screen. Please run with a Framework build of python, and only when you are logged in on the main display of your Mac.’

I think this should be the problem. After I switched my command to
‘pythonw /…/python3.7/site-packages/vespa/simulation/’

It worked!

Do you have any tips on it?
Thanks a lot.


The integral Plot and Contour Plot didn’t show up and the errors below showed up:

( Gtk-CRITICAL **: 22:33:04.533: IA__gtk_widget_set_size_request: assertion ‘width >= -1’ failed

( Gtk-CRITICAL **: 22:33:04.533: IA__gtk_widget_set_size_request: assertion ‘width >= -1’ failed

( Gtk-CRITICAL **: 22:33:04.534: IA__gtk_widget_set_size_request: assertion ‘width >= -1’ failed

** ( CRITICAL **: 22:33:04.597: murrine_style_draw_flat_box: assertion ‘height >= -1’ failed

** ( CRITICAL **: 22:33:04.597: murrine_style_draw_focus: assertion ‘height >= -1’ failed

** ( CRITICAL **: 22:33:04.629: murrine_style_draw_focus: assertion ‘height >= -1’ failed

** ( CRITICAL **: 22:33:04.636: murrine_style_draw_focus: assertion ‘height >= -1’ failed