Problems loading HERMES and MEGA-PRESS dicom data

Hi all,

I am running into some issues when trying to load HERMES and MEGA-PRESS dicom data from a Siemens scanner. For HERMES I get this error message:

Index in position 3 exceeds array bounds (must not exceed 2).

Error in op_takesubspec (line 35)
fids=in.fids(:,:,index);

Error in osp_LoadDICOM (line 86)
raw_ref_C = op_takesubspec(MRSCont.raw_ref{kk},3);

Error in OspreyLoad (line 66)
[MRSCont] = osp_LoadDICOM(MRSCont);

Error in osp_onLoad (line 32)
MRSCont = OspreyLoad(MRSCont);

The data provided are in folders that contain single averages dicom files, so I am not sure what’s going on. I have uploaded a sample in our shared folder in case you have time to take a look at the data I’m using.

As for the MEGA-PRESS data, the issue I ran into was that it would not load the correct basis set. Osprey would identify the sequence as MEGA (from the read_dcm_header.m function) but was missing PRESS, so the osp_fitInitialise.m function would load the basis set from the user folder instead.

I did not run into any issues when using the TWIX files instead, but we were hoping to be able to use the DICOM files as they take less storage and can be easily stored with each subject’s scan.

As always, thanks for any help you can provide.

Best,
-Humberto

Hi Humberto,

I’ve fixed the dicom loader for MEGA-PRESS, MEGA-sLASER, and HERMES. Please let me know whether the latest update fixes the problem.

Best,
Helge

Hi Helge,

So far I’ve tried it for MEGA-PRESS and HERMES, and everything seems to be working. Thanks a lot for fixing this! I will let you know if I run into any issues for MEGA-sLASER.

Best,
-Humberto

Hi Humberto,

that’s great news.

With regards to the MEGA-sLASER, I’m very close to releasing a frequency restricted spectral registration to circumvent the problem with the residual water signal (I’m not sure if this problem still persists or whether you’ve changed the water suppression during the acquisitions). I’ll upload this in the next days, so you may want to hold MEGA-sLASER data for a few days.

Best,
Helge

Hi Humberto,

I’ve just released the frequency restricted spectral registration. You can specify the method in your jobFile by adding opts.SpecReg = 'RobSpecReg'; with three options RobSpecReg which is the standard robust spectral registration, RestrSpecReg which performs a time domain spectral registration but is restricted to the ppm range similar to the specified fit range, and none to omit spectral registration.

Let me know if this works for you.

Best,
Helge

1 Like

Hi Helge,

Thanks a lot for adding this feature! I will go ahead a test it in the next couple days and report back if i run into any issues.

Humberto